#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "assert\.strictEqual\((.*), (.*)\);"
Local $sString = " assert.strictEqual(wrapper.type(), ButtonBase);" & @CRLF & _
" assert.strictEqual(wrapper.hasClass(classes.root), true);" & @CRLF & _
" assert.strictEqual(wrapper.hasClass('woofCollapseSectionSummary'), true);" & @CRLF & _
" assert.strictEqual(itemsWrap.hasClass(classes.content), true);" & @CRLF & _
" assert.strictEqual(wrapper.hasClass(classes.disabled), true);" & @CRLF & _
" assert.strictEqual(wrapper.hasClass(classes.expanded), true);" & @CRLF & _
" assert.strictEqual(iconWrap.hasClass(classes.expandIcon), true);" & @CRLF & _
" assert.strictEqual(wrapper.state().focused, true);" & @CRLF & _
" assert.strictEqual(wrapper.state().focused, false);" & @CRLF & _
" assert.strictEqual(handleChange.callCount, 1);" & @CRLF & _
" assert.strictEqual(handleChange.calledWith(eventMock), true);" & @CRLF & _
" assert.strictEqual(handleChange.callCount, 0);" & @CRLF & _
" assert.strictEqual(handleClick.callCount, 1);" & @CRLF & _
""
Local $sSubst = "expect($1).toEqual($2);"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)