// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[a-zA-Z]{2}[\s*]{0,}[0-9]{2}[\s*]{0,}[a-zA-Z]{1,}[\s*]{0,}[0-9\s]{22,}").unwrap();
let string = "IT 96V03440 551400000 0021 6200";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}