re = /[a-zA-Z]{2}[\s*]{0,}[0-9]{2}[\s*]{0,}[a-zA-Z]{1,}[\s*]{0,}[0-9\s]{22,}/
str = 'IT 96V03440 551400000 0021 6200'
# Print the match result
str.match(re) do |match|
puts match.to_s
end