const regex = /[a-zA-Z]{2}[\s*]{0,}[0-9]{2}[\s*]{0,}[a-zA-Z]{1,}[\s*]{0,}[0-9\s]{22,}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-Z]{2}[\\s*]{0,}[0-9]{2}[\\s*]{0,}[a-zA-Z]{1,}[\\s*]{0,}[0-9\\s]{22,}', '')
const str = `IT 96V03440 551400000 0021 6200`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}