import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z]{2}[\\s*]{0,}[0-9]{2}[\\s*]{0,}[a-zA-Z]{1,}[\\s*]{0,}[0-9\\s]{22,}";
final String string = "IT 96V03440 551400000 0021 6200";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}