re = /^<a((?!title=".*")(\X))*(<\/a>)$/m
str = '<a href="/kaas/fabriek">Hop</a>
<a href="/kaas/fabriek" title="kaas">Hop</a>
<a
href="henk"
title="kaas>
tekst
</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end