import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<a((?!title=\".*\")(\\X))*(<\\/a>)$";
final String string = "<a href=\"/kaas/fabriek\">Hop</a>\n"
+ "<a href=\"/kaas/fabriek\" title=\"kaas\">Hop</a>\n"
+ "<a \n"
+ "href=\"henk\" \n"
+ "title=\"kaas>\n"
+ " tekst\n\n\n\n\n\n\n"
+ "</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}