$re = '/^<a((?!title=".*")(\X))*(<\/a>)$/m';
$str = '<a href="/kaas/fabriek">Hop</a>
<a href="/kaas/fabriek" title="kaas">Hop</a>
<a
href="henk"
title="kaas>
tekst
</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);