#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^<a((?!title=".*")(\X))*(<\/a>)$"
Local $sString = "<a href="/kaas/fabriek">Hop</a>" & @CRLF & _
"<a href="/kaas/fabriek" title="kaas">Hop</a>" & @CRLF & _
"<a " & @CRLF & _
"href="henk" " & @CRLF & _
"title="kaas>" & @CRLF & _
" tekst" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")