using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<a((?!title="".*"")(\X))*(<\/a>)$";
string input = @"<a href=""/kaas/fabriek"">Hop</a>
<a href=""/kaas/fabriek"" title=""kaas"">Hop</a>
<a
href=""henk""
title=""kaas>
tekst
</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}