// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:ecp\.eset\.systems|(?:m\.)?esa\.eset\.com)$").unwrap();
let string = "ecp.eset.systems
esa.eset.com
m.esa.eset.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}