$re = '/^(?:ecp\.eset\.systems|(?:m\.)?esa\.eset\.com)$/mi';
$str = 'ecp.eset.systems
esa.eset.com
m.esa.eset.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);