const regex = /^(?:ecp\.eset\.systems|(?:m\.)?esa\.eset\.com)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:ecp\\.eset\\.systems|(?:m\\.)?esa\\.eset\\.com)$', 'gmi')
const str = `ecp.eset.systems
esa.eset.com
m.esa.eset.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}