re = /^(?:ecp\.eset\.systems|(?:m\.)?esa\.eset\.com)$/mi
str = 'ecp.eset.systems
esa.eset.com
m.esa.eset.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end