package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:ecp\.eset\.systems|(?:m\.)?esa\.eset\.com)$`)
var str = `ecp.eset.systems
esa.eset.com
m.esa.eset.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}