import Foundation
let pattern = #"(?:https?:\/\/)?(?:www\.)?youtu\.?be(?:\.com)?\/?.*(?:watch|embed)?(?:.*v=|v\/|\/)([\w\-_]+)\&?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.youtube.com/watch?v=iwGFalTRHDA
http://www.youtube.com/watch?v=iwGFalTRHDA
http://youtu.be/embed/iwGFalTRHDA
http://youtu.be/n17B_uFF4cA
http://www.youtube.com/embed/iwGFalTRHDA
http://youtu.be/t-ZRX8984sc
https://www.youtube.com/embed/UIpuNuV23v0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0/modestbranding=1&rel=0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)