// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:https?:\/\/)?(?:www\.)?youtu\.?be(?:\.com)?\/?.*(?:watch|embed)?(?:.*v=|v\/|\/)([\w\-_]+)\&?").unwrap();
let string = "http://www.youtube.com/watch?v=iwGFalTRHDA
http://www.youtube.com/watch?v=iwGFalTRHDA
http://youtu.be/embed/iwGFalTRHDA
http://youtu.be/n17B_uFF4cA
http://www.youtube.com/embed/iwGFalTRHDA
http://youtu.be/t-ZRX8984sc
https://www.youtube.com/embed/UIpuNuV23v0";
let substitution = "$0/modestbranding=1&rel=0";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}