$re = '/(?:https?:\/\/)?(?:www\.)?youtu\.?be(?:\.com)?\/?.*(?:watch|embed)?(?:.*v=|v\/|\/)([\w\-_]+)\&?/m';
$str = 'http://www.youtube.com/watch?v=iwGFalTRHDA
http://www.youtube.com/watch?v=iwGFalTRHDA
http://youtu.be/embed/iwGFalTRHDA
http://youtu.be/n17B_uFF4cA
http://www.youtube.com/embed/iwGFalTRHDA
http://youtu.be/t-ZRX8984sc
https://www.youtube.com/embed/UIpuNuV23v0';
$subst = "$0/modestbranding=1&rel=0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;