use strict;
my $str = 'http://www.youtube.com/watch?v=iwGFalTRHDA
http://www.youtube.com/watch?v=iwGFalTRHDA
http://youtu.be/embed/iwGFalTRHDA
http://youtu.be/n17B_uFF4cA
http://www.youtube.com/embed/iwGFalTRHDA
http://youtu.be/t-ZRX8984sc
https://www.youtube.com/embed/UIpuNuV23v0';
my $regex = qr/(?:https?:\/\/)?(?:www\.)?youtu\.?be(?:\.com)?\/?.*(?:watch|embed)?(?:.*v=|v\/|\/)([\w\-_]+)\&?/mp;
my $subst = '$0/modestbranding=1&rel=0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";