import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?:\\/\\/)?(?:www\\.)?youtu\\.?be(?:\\.com)?\\/?.*(?:watch|embed)?(?:.*v=|v\\/|\\/)([\\w\\-_]+)\\&?";
final String string = "http://www.youtube.com/watch?v=iwGFalTRHDA\n"
+ "http://www.youtube.com/watch?v=iwGFalTRHDA\n"
+ "http://youtu.be/embed/iwGFalTRHDA\n"
+ "http://youtu.be/n17B_uFF4cA\n"
+ "http://www.youtube.com/embed/iwGFalTRHDA\n"
+ "http://youtu.be/t-ZRX8984sc\n"
+ "https://www.youtube.com/embed/UIpuNuV23v0";
final String subst = "$0/modestbranding=1&rel=0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}