// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(http(s)?(:\/\/))?(www\.)?[a-zA-Z0-9-_\.]+(\.[a-zA-Z0-9]{2,})([-a-zA-Z0-9:%_\+.~#?&\/\/=]*)").unwrap();
let string = "http://google.com
www.google.com
https://google.com
http://www.google.com/
http://www.google.co.th
http://www.สวสัดดีครบั.co.th
http://123.12.20.11
www.google.com
https://regex101.com/r/vM7wT6/2
https://www.google.co.th/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=regular+expression+url+ios
https://www.google.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}