package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(http(s)?(:\/\/))?(www\.)?[a-zA-Z0-9-_\.]+(\.[a-zA-Z0-9]{2,})([-a-zA-Z0-9:%_\+.~#?&\/\/=]*)`)
var str = `http://google.com
www.google.com
https://google.com
http://www.google.com/
http://www.google.co.th
http://www.สวสัดดีครบั.co.th
http://123.12.20.11
www.google.com
https://regex101.com/r/vM7wT6/2
https://www.google.co.th/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=regular+expression+url+ios
https://www.google.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}