import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(http(s)?(:\\/\\/))?(www\\.)?[a-zA-Z0-9-_\\.]+(\\.[a-zA-Z0-9]{2,})([-a-zA-Z0-9:%_\\+.~#?&\\/\\/=]*)";
final String string = "http://google.com\n"
+ "www.google.com\n"
+ "https://google.com\n"
+ "http://www.google.com/\n"
+ "http://www.google.co.th\n"
+ "http://www.สวสัดดีครบั.co.th\n"
+ "http://123.12.20.11\n"
+ "www.google.com\n"
+ "https://regex101.com/r/vM7wT6/2\n"
+ "https://www.google.co.th/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=regular+expression+url+ios\n\n"
+ "https://www.google.com\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}