$re = '/^(http(s)?(:\/\/))?(www\.)?[a-zA-Z0-9-_\.]+(\.[a-zA-Z0-9]{2,})([-a-zA-Z0-9:%_\+.~#?&\/\/=]*)/m';
$str = 'http://google.com
www.google.com
https://google.com
http://www.google.com/
http://www.google.co.th
http://www.สวสัดดีครบั.co.th
http://123.12.20.11
www.google.com
https://regex101.com/r/vM7wT6/2
https://www.google.co.th/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=regular+expression+url+ios
https://www.google.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);