#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(http(s)?(:\/\/))?(www\.)?[a-zA-Z0-9-_\.]+(\.[a-zA-Z0-9]{2,})([-a-zA-Z0-9:%_\+.~#?&\/\/=]*)"
Local $sString = "http://google.com" & @CRLF & _
"www.google.com" & @CRLF & _
"https://google.com" & @CRLF & _
"http://www.google.com/" & @CRLF & _
"http://www.google.co.th" & @CRLF & _
"http://www.สวสัดดีครบั.co.th" & @CRLF & _
"http://123.12.20.11" & @CRLF & _
"www.google.com" & @CRLF & _
"https://regex101.com/r/vM7wT6/2" & @CRLF & _
"https://www.google.co.th/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=regular+expression+url+ios" & @CRLF & _
"" & @CRLF & _
"https://www.google.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")