$re = '/^\+?1?\W*([2-9]{3})\W*([2-9]{3})[\s.-]*(\d{4})\s*$/m';
$str = '(223) 456-7890
223.456.7890
223 456 7890
+1 (223) 456-7890
+1 (223) 456-7890
123456789
22234567890
12234567890
+1 (223) 456-7890
321234567890
123-abc-7890
123-@:!-7890
(023) 456-7890
(123) 456-7890
(223) 056-7890
(223) 156-7890
1 (023) 456-7890
1 (123) 456-7890
1 (223) 056-7890
1 (223) 056-7890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);