#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+?1?\W*([2-9]{3})\W*([2-9]{3})[\s.-]*(\d{4})\s*$"
Local $sString = "(223) 456-7890" & @CRLF & _
"223.456.7890" & @CRLF & _
"223 456 7890 " & @CRLF & _
"+1 (223) 456-7890" & @CRLF & _
"+1 (223) 456-7890" & @CRLF & _
"123456789" & @CRLF & _
"22234567890" & @CRLF & _
"12234567890" & @CRLF & _
"+1 (223) 456-7890" & @CRLF & _
"321234567890" & @CRLF & _
"123-abc-7890" & @CRLF & _
"123-@:!-7890" & @CRLF & _
"(023) 456-7890" & @CRLF & _
"(123) 456-7890" & @CRLF & _
"(223) 056-7890" & @CRLF & _
"(223) 156-7890" & @CRLF & _
"1 (023) 456-7890" & @CRLF & _
"1 (123) 456-7890" & @CRLF & _
"1 (223) 056-7890" & @CRLF & _
"1 (223) 056-7890"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")