import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+?1?\\W*([2-9]{3})\\W*([2-9]{3})[\\s.-]*(\\d{4})\\s*$";
final String string = "(223) 456-7890\n"
+ "223.456.7890\n"
+ "223 456 7890 \n"
+ "+1 (223) 456-7890\n"
+ "+1 (223) 456-7890\n"
+ "123456789\n"
+ "22234567890\n"
+ "12234567890\n"
+ "+1 (223) 456-7890\n"
+ "321234567890\n"
+ "123-abc-7890\n"
+ "123-@:!-7890\n"
+ "(023) 456-7890\n"
+ "(123) 456-7890\n"
+ "(223) 056-7890\n"
+ "(223) 156-7890\n"
+ "1 (023) 456-7890\n"
+ "1 (123) 456-7890\n"
+ "1 (223) 056-7890\n"
+ "1 (223) 056-7890";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}