const regex = /^\+?1?\W*([2-9]{3})\W*([2-9]{3})[\s.-]*(\d{4})\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+?1?\\W*([2-9]{3})\\W*([2-9]{3})[\\s.-]*(\\d{4})\\s*$', 'gm')
const str = `(223) 456-7890
223.456.7890
223 456 7890
+1 (223) 456-7890
+1 (223) 456-7890
123456789
22234567890
12234567890
+1 (223) 456-7890
321234567890
123-abc-7890
123-@:!-7890
(023) 456-7890
(123) 456-7890
(223) 056-7890
(223) 156-7890
1 (023) 456-7890
1 (123) 456-7890
1 (223) 056-7890
1 (223) 056-7890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}