package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+?1?\W*([2-9]{3})\W*([2-9]{3})[\s.-]*(\d{4})\s*$`)
var str = `(223) 456-7890
223.456.7890
223 456 7890
+1 (223) 456-7890
+1 (223) 456-7890
123456789
22234567890
12234567890
+1 (223) 456-7890
321234567890
123-abc-7890
123-@:!-7890
(023) 456-7890
(123) 456-7890
(223) 056-7890
(223) 156-7890
1 (023) 456-7890
1 (123) 456-7890
1 (223) 056-7890
1 (223) 056-7890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}