re = /^([^;,\n]*)(;.*\b\1\b=|;.*;|;)([^;=,\n]+)(,.*|;)?$/m
str = '# with k/v pairs declared
http-metrics;http-metrics=/~/healthy;
http-metrics;http-metrics=/~/read;
http-metrics;http-metrics=/ping,http-service=/ping,proxy-test=/proxy
http-service;http-metrics=/ping2,http-service=/ping
http-service;http-metrics=/ping2,http-test=/ping
http-metrics;;http-metrics=/~/healthy
http-metrics;http-metrics=/~/read;
http-metrics;;http-service=/ping
http-metrics;;/ping
http-metrics;/ping;
;;/~/healthy
;/~/healthy;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end