import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^;,\\n]*)(;.*\\b\\1\\b=|;.*;|;)([^;=,\\n]+)(,.*|;)?$";
final String string = "# with k/v pairs declared\n"
+ "http-metrics;http-metrics=/~/healthy;\n"
+ "http-metrics;http-metrics=/~/read;\n"
+ "http-metrics;http-metrics=/ping,http-service=/ping,proxy-test=/proxy\n"
+ "http-service;http-metrics=/ping2,http-service=/ping\n"
+ "http-service;http-metrics=/ping2,http-test=/ping\n"
+ "http-metrics;;http-metrics=/~/healthy\n"
+ "http-metrics;http-metrics=/~/read;\n"
+ "http-metrics;;http-service=/ping\n"
+ "http-metrics;;/ping\n"
+ "http-metrics;/ping;\n"
+ ";;/~/healthy\n"
+ ";/~/healthy;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}