use strict;
my $str = '# with k/v pairs declared
http-metrics;http-metrics=/~/healthy;
http-metrics;http-metrics=/~/read;
http-metrics;http-metrics=/ping,http-service=/ping,proxy-test=/proxy
http-service;http-metrics=/ping2,http-service=/ping
http-service;http-metrics=/ping2,http-test=/ping
http-metrics;;http-metrics=/~/healthy
http-metrics;http-metrics=/~/read;
http-metrics;;http-service=/ping
http-metrics;;/ping
http-metrics;/ping;
;;/~/healthy
;/~/healthy;';
my $regex = qr/^([^;,\n]*)(;.*\b\1\b=|;.*;|;)([^;=,\n]+)(,.*|;)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}