const regex = /^([^;,\n]*)(;.*\b\1\b=|;.*;|;)([^;=,\n]+)(,.*|;)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^;,\\n]*)(;.*\\b\\1\\b=|;.*;|;)([^;=,\\n]+)(,.*|;)?$', 'gm')
const str = `# with k/v pairs declared
http-metrics;http-metrics=/~/healthy;
http-metrics;http-metrics=/~/read;
http-metrics;http-metrics=/ping,http-service=/ping,proxy-test=/proxy
http-service;http-metrics=/ping2,http-service=/ping
http-service;http-metrics=/ping2,http-test=/ping
http-metrics;;http-metrics=/~/healthy
http-metrics;http-metrics=/~/read;
http-metrics;;http-service=/ping
http-metrics;;/ping
http-metrics;/ping;
;;/~/healthy
;/~/healthy;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}