#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^;,\n]*)(;.*\b\1\b=|;.*;|;)([^;=,\n]+)(,.*|;)?$"
Local $sString = "# with k/v pairs declared" & @CRLF & _
"http-metrics;http-metrics=/~/healthy;" & @CRLF & _
"http-metrics;http-metrics=/~/read;" & @CRLF & _
"http-metrics;http-metrics=/ping,http-service=/ping,proxy-test=/proxy" & @CRLF & _
"http-service;http-metrics=/ping2,http-service=/ping" & @CRLF & _
"http-service;http-metrics=/ping2,http-test=/ping" & @CRLF & _
"http-metrics;;http-metrics=/~/healthy" & @CRLF & _
"http-metrics;http-metrics=/~/read;" & @CRLF & _
"http-metrics;;http-service=/ping" & @CRLF & _
"http-metrics;;/ping" & @CRLF & _
"http-metrics;/ping;" & @CRLF & _
";;/~/healthy" & @CRLF & _
";/~/healthy;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")