import Foundation
let pattern = #"function(\s*)\(((\S+,* *)*)\)(\s*){"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
function (param1, param2){
//
}
function (){
//
}
function() {
//
}
function (param1, param2){
//
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"($2) => {"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)