package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`function(\s*)\(((\S+,* *)*)\)(\s*){`)
var str = `function (param1, param2){
//
}
function (){
//
}
function() {
//
}
function (param1, param2){
//
}`
var substitution = "($2) => {"
fmt.Println(re.ReplaceAllString(str, substitution))
}