re = /function(\s*)\(((\S+,* *)*)\)(\s*){/
str = 'function (param1, param2){
//
}
function (){
//
}
function() {
//
}
function (param1, param2){
//
}'
subst = '($2) => {'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result