$re = '/function(\s*)\(((\S+,* *)*)\)(\s*){/';
$str = 'function (param1, param2){
//
}
function (){
//
}
function() {
//
}
function (param1, param2){
//
}';
$subst = "($2) => {";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;