// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"function(\s*)\(((\S+,* *)*)\)(\s*){").unwrap();
let string = "function (param1, param2){
//
}
function (){
//
}
function() {
//
}
function (param1, param2){
//
}";
let substitution = "($2) => {";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}