re = /(?P<device_name>\w+)(?P<is_connected> (connected|disconnected))(?P<is_primary> primary)? ((?P<resolution_width>\d+)x(?P<resolution_height>\d+)\+(?P<offset_width>\d+)\+(?P<offset_height>\d+)) \(normal left inverted right x axis y axis\) ((?P<dimension_width>\d+)mm x (?P<dimension_height>\d+)mm)?/m
str = 'eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 310mm x 170mm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end