import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<device_name>\\w+)(?P<is_connected> (connected|disconnected))(?P<is_primary> primary)? ((?P<resolution_width>\\d+)x(?P<resolution_height>\\d+)\\+(?P<offset_width>\\d+)\\+(?P<offset_height>\\d+)) \\(normal left inverted right x axis y axis\\) ((?P<dimension_width>\\d+)mm x (?P<dimension_height>\\d+)mm)?";
final String string = "eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 310mm x 170mm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}