const regex = /(?P<device_name>\w+)(?P<is_connected> (connected|disconnected))(?P<is_primary> primary)? ((?P<resolution_width>\d+)x(?P<resolution_height>\d+)\+(?P<offset_width>\d+)\+(?P<offset_height>\d+)) \(normal left inverted right x axis y axis\) ((?P<dimension_width>\d+)mm x (?P<dimension_height>\d+)mm)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<device_name>\\w+)(?P<is_connected> (connected|disconnected))(?P<is_primary> primary)? ((?P<resolution_width>\\d+)x(?P<resolution_height>\\d+)\\+(?P<offset_width>\\d+)\\+(?P<offset_height>\\d+)) \\(normal left inverted right x axis y axis\\) ((?P<dimension_width>\\d+)mm x (?P<dimension_height>\\d+)mm)?', 'gm')
const str = `eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 310mm x 170mm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}