#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<device_name>\w+)(?P<is_connected> (connected|disconnected))(?P<is_primary> primary)? ((?P<resolution_width>\d+)x(?P<resolution_height>\d+)\+(?P<offset_width>\d+)\+(?P<offset_height>\d+)) \(normal left inverted right x axis y axis\) ((?P<dimension_width>\d+)mm x (?P<dimension_height>\d+)mm)?"
Local $sString = "eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 310mm x 170mm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")