# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<device_name>\w+)(?P<is_connected> (connected|disconnected))(?P<is_primary> primary)? ((?P<resolution_width>\d+)x(?P<resolution_height>\d+)\+(?P<offset_width>\d+)\+(?P<offset_height>\d+)) \(normal left inverted right x axis y axis\) ((?P<dimension_width>\d+)mm x (?P<dimension_height>\d+)mm)?"
test_str = "eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 310mm x 170mm"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.