// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w+)\s*\((\w)\)\s*->\s*(\w+)").unwrap();
let string = "q0 (a) -> q1
q1 (b) -> q2";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}