re = /(\w+)\s*\((\w)\)\s*->\s*(\w+)/m
str = 'q0 (a) -> q1
q1 (b) -> q2'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result