$re = '/(\w+)\s*\((\w)\)\s*->\s*(\w+)/m';
$str = 'q0 (a) -> q1
q1 (b) -> q2';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;