package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)\s*\((\w)\)\s*->\s*(\w+)`)
var str = `q0 (a) -> q1
q1 (b) -> q2`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}