# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+)\s*\((\w)\)\s*->\s*(\w+)//gm;t' <<< "q0 (a) -> q1
q1 (b) -> q2"